sound issues Spectrum LX bass

View previous topic View next topic Go down

Poll sound issues Spectrum LX bass

Post by zl1wt on Fri Dec 14, 2012 1:55 am

Hi all,
Did anyone have a problem like I'm having? Yesterday when practicing I had issues with my bass. Plugged into a DI box, into a church sound system I found that I was only getting some noise when the volume was full on. Ok, I thought it could be the batteries that needed replacing and yep, both were at around 8.5 volt. Duly replaced. Tried it tonite and still the same issue. The pull / push switch does not seem to make any issue. I do have an option at church playing a Hammer from Slammer but hey, it's not the same... What am I looking at? faulty switch? How do I test the switch?
Any info appreciated. email direct if want to Sad

Registered Member

Number of posts : 5
Registration date : 2012-06-12

Back to top Go down

Poll Re: sound issues Spectrum LX bass

Post by Westbone on Fri Dec 14, 2012 3:16 am

As a first step i'd clean all switches and jack ect. with a good quality switch cleaner and retest directly into an amp.

DO NOT use WD 40 or the like

Financial supporter

Number of posts : 4802
Location : Redbridge
Registration date : 2008-12-28

Back to top Go down

Poll Re: sound issues Spectrum LX bass

Post by Barry on Fri Dec 14, 2012 9:11 pm

You wouldn't believe how many problems are caused by a bit of crud on a contact point. Absolutely no WD40!

"A little song. A little dance. A little seltzer down your pants." -Chuckles the Clown

MUSIC/PIX/VIDEOS: (including Spectrum ST)

Hero, Legend, and all round good guy

Number of posts : 6060
Age : 71
Location : Port Weller, St. Catharines, Canada
Registration date : 2009-05-01

Back to top Go down

Poll Re: sound issues Spectrum LX bass

Post by Sponsored content Today at 7:18 am

Sponsored content

Back to top Go down

View previous topic View next topic Back to top

- Similar topics

Permissions in this forum:
You cannot reply to topics in this forum